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1 Introduction and Overview

SNAP! dcs is a handheld data collection system designed to make any typical field data collection
form available in an electronic format on an MS Windows Mobile device or an iPhone / iPod Touch.

There are three parts to SNAP!:
· SNAP! Client: desktop software that stores card templates and makes them available to a

mobile device, iPhone, or iPod Touch.  Cards and corresponding data collected on the
mobile device are imported to the desktop for storage, viewing, editing, analyzing, exporting,
and printing.

· SNAP! Mobile: users load forms onto a MS Windows Mobile device from SNAP! Client.  Data
is collected and stored on the handheld, then exported to the Client.

· iSNAP!: users load forms onto an iPhone or iPod Touch from SNAP! Client through Dropbox
(free, third-party online software).  Data is collected and stored on the iPhone or iPod Touch,
then exported to the Client via Dropbox.
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2 Getting Started

Setting up SNAP! involves the following steps:
1. Installing the desktop software
2. Installing the handheld software or iPhone/iPod Touch software
3. Creating themes (optional)
4. Importing card templates to the desktop
5. Sending the card templates to the handheld or iPhone/iPod Touch

2.1 Minimum System Requirements

Desktop Requirements:
· .NET Framework 3.5 (found at www.microsoft.com/downloads)
· Intel® Pentium® processor 400 MHz minimum (1GHz recommended)
· Windows XP or newer, Windows Server 2003 or 2008
· 96MB RAM minimum (256MB RAM recommended)
· Up to 500MB hard drive space may be required
· Microsoft ActiveSync or Windows Mobile Device Center
· Microsoft Excel (to run reports)

Handheld Requirements:
· .NET Compact Framework 3.5 (found at www.microsoft.com/downloads)
· Windows CE or Windows Mobile

iPhone/iPod Touch Requirements:
· iOS4 operating system
· iPod Touch requires wifi for syncing data with SNAP! Client

2.2 Installing SNAP!

To install SNAP!, you must first have some basic software installed on the desktop and on the mobile
device (if you are using one):

1. Microsoft ActiveSync or Windows Mobile Device Center must be installed to connect
your handheld to your PC.
Windows Mobile Device Center for Windows Mobile (2003 or later) devices and Windows
Vista or Windows 7:
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-download

.mspx

Microsoft ActiveSync for Windows CE or Mobile devices and Windows XP or earlier:
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7269173a-28bf-
4cac-a682-58d3233efb4c

Microsoft ActiveSync for Windows Mobile (2003 or later) devices and Windows XP or earlier:
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.m

spx

2. .NET Framework 3.5 must be installed on the desktop:
http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508
D977D32A6&displaylang=en

3. .NET Compact Framework 3.5 must be installed on the handheld (connect handheld to
PC prior to downloading):

http://www.microsoft.com/downloads
http://www.microsoft.com/downloads
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-download.mspx
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/device-center-download.mspx
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7269173a-28bf-4cac-a682-58d3233efb4c
http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=7269173a-28bf-4cac-a682-58d3233efb4c
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.mspx
http://www.microsoft.com/windowsmobile/en-us/downloads/microsoft/activesync-download.mspx
http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyId=333325FD-AE52-4E35-B531-508D977D32A6&displaylang=en
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http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-00413
45b3385&displaylang=en

Once these are installed, SNAP! can be installed on the desktop and mobile device and/or
iPhone/iPod Touch.

2.2.1 Desktop Installation (SNAP! Client)

SNAP! Client installation on PC:
1. Run the installer and follow the on-screen instructions from

http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP.
2. If this is the initial installation, run SNAP Client and register the program by entering your

Registration Code.  The PC must be connected to the internet in order to register.  You will
not be able to unregister a PC once registered, so please ensure you register the correct PC.

** Note:  Templates and cards are stored in the Program Data\JRP\SnapClient4 location by default.
If you wish to store them elsewhere, you can specify a different location (ex. C:\My Documents) in a
sharedfolder.txt document in the SnapClient installation folder (generally under C:\Program Files\JRP
Solutions).

2.2.2 Mobile Device Installation (SNAP! Mobile)

SNAP! Mobile installation on a Windows Mobile or CE handheld device:
1. Install SNAP! Client on the PC first.
2. For new installations, go to http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP and

download the 'Download Version for Mobile Device'.  This will download a .CAB file.
3. Ensure that your mobile device is connected and synchronized with your desktop.  
4. Locate the downloaded SnapMobileSetup.CAB file on your computer, copy it, and paste it

into the main directory of your mobile device (not the storage card).
5. On the mobile device itself, locate the SnapMobileSetup.CAB file and select it.  This will

install SNAP onto your handheld.
6. For upgrades, open SNAP! on the desktop and choose the Mobile Device menu, use the 

Install to Device button in the bottom left, and follow the prompts on the mobile device.
7. You can now access SNAP! from your handheld by either going to the Programs menu or

directly off the Start menu.
8. To load card templates onto your handheld, review 'Loading Templates / Themes onto

SNAP! Mobile'.

2.2.3 iPhone/iPod Touch Installation (iSNAP!)

From the App Store on your iPhone or iPod Touch, search for 'iSNAP by JRP Solutions' and install
the application (you will need an Apple ID).

To load templates and cards onto your device, refer to 'Loading Template / Themes onto iPhone /
iPod Touch'.

2.3 Upgrading SNAP!

SNAP! Client upgrading on PC:
1. Run the installer and follow the on-screen instructions from

http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP.

SNAP! Mobile upgrading on a Windows Mobile or CE handheld device:
1. Ensure that your mobile device is connected and merge the handheld data with the desktop

data.
2. For upgrades, open SNAP! on the desktop and choose 'Install to Mobile Device' from the

Mobile Device menu and follow the prompts on the mobile device.

http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3385&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3385&displaylang=en
http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP
http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP
http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP
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3. You can now access SNAP! from your handheld by either going to the Programs menu or
directly off the Start menu.

4. To load card templates onto your handheld, review 'Loading Templates / Themes onto
SNAP! Mobile'.

iSNAP! upgrading on iPhone or iPod Touch:
1. Check the App Store for updates to 'iSNAP by JRP Solutions' and install if available.

2.4 SNAP! Terminology

Template – the format for entering and reporting data; a particular type of card
Theme – a user-customized template for entering and reporting data
Cards – the container for some data collected; a card created using a template
Data – all data in the database or card

2.5 Data Types

There can be several different types of data entry fields available on each card type:
· Checkbox - check the box if applicable (boolean field)
· Date – drop down calendar to select date
· Fixed Drop Down – select from a pull down list of codes, no manual entry
· Floating Point – decimal number field, indicated in green
· Formula – automatically calculated field
· Free Text Drop Down – select from a pull down list of codes or manual entry
· General Text – manual entry text
· Integer – whole number field, indicated in blue
· Label – displays a heading without the option to collect data
· Multi Select – select multiple options from a list
· Tally - select Ù or Ú buttons to increase or decrease the count (cannot go below zero),

shown in green
· Calculated - not a data entry field, shown in green
· Y N NA NC – checklist, select Y / N / na / X (clear) – can use keyboard ‘y’, ‘n’, ‘x’, ‘c’ or

mouse

· Comments, Sketch, Voice Clips, Attachments, GPS – select the  beside the field name
to enter comments, draw a sketch, record an audio clip, add attachments, or to set GPS
coordinates (if connected)

· Mandatory – any mandatory fields are in yellow

· Information / Help – select the  beside the field name for more information
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3 Using SNAP!

SNAP! Client is desktop software that stores card templates and their themes and makes them
available to a mobile device.  Cards and corresponding data collected on the mobile device are
imported to the desktop for storage, viewing, editing, analyzing, and printing.

3.1 Templates and Themes

Templates are the blank forms for collecting data.  While JRP Solutions builds the initial card
templates, users can edit some parts of the templates to create themes and then share these with
other users.  This is very useful when different codes are needed in the code lists, or different
terminology is used.  

To edit a template, you must have it selected, then choose the Themes menu and ‘Create a new
[template name] Theme based on the Default Template’.  If you have a theme already selected, you
can create another theme based on it.  Once a theme has been created, it cannot be edited.  This is
to prevent shared themes from becoming different between users.  Old themes can be deleted if
selected first. 
 
Templates and themes are distributed by exporting and importing .SnapPkg files.  They are loaded
onto SNAP! Client where they can be sent to SNAP! Mobile or iSNAP! for data collection in the field.

To select a card template or theme on the desktop, use the Change Template button.  On the
mobile device, use the Current Template pull down list to select the template or theme.  On the
iPhone or iPod Touch, select a project (which is associated with a specific template).

The following fields can be edited to create a theme:
· Section - the Text, Fill, and Border colors for the Header Text (on the desktop only) can be

edited
· Long Name – the field name that appears when using the Cards tab on the desktop
· Short Name – the field name that appears on the handheld and the Analysis tab on the

desktop
· Required on Handheld – select if this field is mandatory
· Users Can Set Default Value on Handheld – means users can provide default data on

the handheld that will be used on every new card created
· Form View Formatting – specify label and value formatting (justification, bold, italic, font

size)
· Decimal Places – specify new decimal places for floating point numbers fields 
· Hide Border – hide the border around a field
· Help Text – provides extra information to users on the handheld
· Code List – lets you edit and reorder the codes available in a pull down list

3.1.1 SNAP! Client

This section explains how to load, upgrade, and delete templates and themes to/from your desktop.

3.1.1.1 Loading Templates / Themes

To load card templates and themes onto the desktop:
1. In SNAP! Client, select ‘Import' > 'from SNAP Data Package’ from the File menu
2. Navigate to the appropriate .SnapPkg file(s) that you received from JRP Solutions or another

user and ‘Open’
3. The default card template or theme will be copied into the Template list
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3.1.1.2 Upgrading Templates

Occasionally JRP Solutions sends out template changes.  Previous templates are not overwritten, but
instead new templates are created and distributed (with a date stamp).  Card data and themes
(customizations) from older templates can be migrated forward into a new template assuming the
template has not changed dramatically.

Please ensure that all necessary data has been merged from the handheld to the desktop before
upgrading.

To install the new template:
1. Choose 'File' > 'Import' > 'from .SNAP Data Package'
2. Navigate to the new .SnapPkg file(s) and ‘Open’
3. The new default card template or theme will be copied into the Template list

To migrate existing cards into a new template:
1. Backup the cards to be migrated into a .SnapPkg file (this also backs up the older template/

theme)
2. Select the old template from the Change Template button
3. From the Edit menu, choose 'Migrate Multiple Cards' and select the new template from the

list
4. Select the cards you wish to migrate, and choose 'OK'

If there were any themes created on the old template that need to be used in the new
template:

1. Choose 'Edit' > 'Migrate Theme From Other Template' and select the theme you want
2. Select the theme from the Change Template button

3.1.1.3 Sharing Templates / Themes

Themes can be created which allow a user to customize certain aspects of a template (colors, field
names, label and value formatting, help text, and code lists).  Once a theme is set up for a particular
purpose, it should be shared with all of the users involved in collecting data.  This will allow them to
all use the same code lists and other customizations, keeping the data more standardized.

To share card templates and themes with other users:
1. In SNAP! Client, select ‘Export' > 'Export Cards as SNAP Package’ from the File menu
2. If there are any cards you wish to include with the template / theme, select them
3. Choose a name and location to save the .SnapPkg file
4. Distribute this file to other users

3.1.1.4 Deleting Templates / Themes

Please ensure that you backup (export .SnapPkg) the template / theme and its cards on the desktop
before deleting.

To delete a template from the desktop, the related card data must be deleted first.  Once all cards are
deleted, use the Themes menu to 'Delete Template'.

To delete a theme from the desktop, make sure it is selected, then use the Themes menu and choose
'Delete [theme name]'.

3.1.2 SNAP! Mobile

This section explains how to load, upgrade, and delete templates and themes to/from your mobile
device.
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3.1.2.1 Loading Templates / Themes

To load card templates onto a handheld:
1. Ensure your mobile device is connected to your computer
2. In SNAP! Client, select the Mobile Device menu
3. Select the template, themes, and cards you would like to add to the handheld.  You have the

option of selecting each item individually, or you can use the buttons at the bottom to do bulk
functions.

4. In SNAP! on the handheld, select the Reload button in the bottom right-hand corner of the
screen to see the new template and/or themes

3.1.2.2 Upgrading Templates

Once the templates have been upgraded on SNAP! Client, they can be sent to the mobile device. 
Please ensure that all necessary data has been merged from the handheld to the desktop before
upgrading.

To install the new template:
1. Select the Mobile Device menu
2. Select the new template, theme and associated cards you wish to put on the mobile device
3. You can also select which template(s) / theme(s) you wish to remove from the device (this

will help clean up the device and prevent data being collected on an older template)
4. Select the Reload button on the handheld to see the new template / theme

3.1.2.3 Deleting Templates / Themes

To delete a theme from the mobile device, select it, then using the Options menu, go to the theme
name and choose 'Remove Theme'.

To remove a template / theme from the mobile device, connect to the desktop and select the Mobile
Device menu.  Themes with a checkbox   under Status and an  under Action can be removed by
selecting them.  You can remove more than one at a time by using the  button at the bottom.

3.1.3 iSNAP!

This section explains how to load, upgrade, and delete templates and themes to/from your iPhone or
iPod Touch.

3.1.3.1 Loading Templates / Themes

To load templates and cards onto your device, you will need to create a Dropbox account, upload
cards from the desktop, then download them onto your iPhone / iPod Touch:

1. To create a Dropbox account, go to www.dropbox.com and choose 'Log in' from the top right
corner of the screen.  Select the 'Create an account' link and follow the directions.  You do
not need to download Dropbox.

2. Using SNAP! Client, select the template or theme that contains the cards you wish to send to
the iPhone or iPod Touch.

3. Select 'Manage Projects' from the Dropbox menu and enter your Dropbox login information.
4. For new templates or projects use the New Project button to create a project to upload

cards into.
5. To add cards to an existing project, select the project from the list and use the Add Cards

button.
6. Select which cards you wish to upload to Dropbox and make available to iSNAP!.
7. The first time you run iSNAP!, choose 'Import from Dropbox' from the Import Options section

and you will be asked to enter your Dropbox account information.
8. Subsequent use of iSNAP!, will automatically show the projects already on your device.  To

add new templates or cards, use the  Dropbox button in the bottom right corner of the
screen.

http://www.dropbox.com
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9. You will see the project(s) available under the Dropbox section.  Tap a project to download it
to your device.

10. To download projects from another Dropbox user account, select the  Dropbox button,
then the Change User button and login with the user's credentials.

3.1.3.2 Upgrading Templates

Once the templates have been upgraded on SNAP! Client, they can be sent to the iPhone or iPod
Touch via Dropbox.  Please ensure that all necessary data has been merged from the device to the
desktop before upgrading.  If a theme has been updated, sync the old one first, delete the theme off
the device, then load the new one.

3.1.3.3 Deleting Templates / Themes

To delete templates / themes / cards from the iPhone or iPod Touch, you first need to sync with
Dropbox.  Once synced, the project will get a green check mark beside it.  Swipe your finger to the
left or right on the project and the check mark will become a Delete button.  Use this to delete the
project (which will delete all related cards).

3.2 Cards and Data

Cards are created from templates and are used to store field data.  Cards can be transferred between
the desktop and the handheld, or the desktop and an iPhone or iPod Touch.  They can be analyzed,
printed, and exported to MS Excel.

3.2.1 SNAP! Client

This section explains how to load, create, edit, view, merge, backup and restore, export, delete,
analyze, and print cards and data on your desktop.  

For instructions on how to send or retrieve cards from a mobile device, please refer to the SNAP!
Mobile > Loading Cards and Importing Cards sections.

For instructions on how to send or retrieve cards from an iPhone or iPod Touch, please refer to the 
iSNAP! > Loading Cards and Importing Cards sections.

3.2.1.1 Loading Cards

There are two options for importing cards under the 'File' > 'Import' menu:
1. from Excel sheet - allows users to specify an import from an Excel spreadsheet
2. from SNAP Data Package - users can import cards contained within a data package created

from SNAP! 3.0 and newer

** IMPORTANT NOTE: If you are starting a database by importing a MS Excel file, and require
multiple people to have access to the file, it is important that ONE person import the Excel file, and
then export a .SnapPkg file to distribute to the others. This will ensure all users are able to sync with
each other.

3.2.1.2 Sharing Cards

Cards can be shared with other users by exchanging SNAP Data Packages (.SnapPkg).

To share cards with other users:
1. In SNAP! Client, select ‘Export' > 'Export Cards as SNAP Package’ from the File menu
2. Select which cards you wish to include
3. Choose a name and location to save the .SnapPkg file
4. Distribute this file to other users
5. On the receiving end, users will use 'Import' > 'from SNAP Data Package' from the File menu
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** IMPORTANT NOTE: If you are starting a database by importing a MS Excel file, and require
multiple people to have access to the file, it is important that ONE person import the Excel file, and
then export a .SnapPkg file to distribute to the others. This will ensure all users are able to sync with
each other.

3.2.1.3 Creating, Editing and Viewing Cards

Use the Filter button  to find a card or group of cards to view.  You can sort the cards for
easier viewing.  If there are filters that you use repeatedly, create a favorite for quicker filtering.  The 
Filter button will turn green when a filter is applied.

You can group cards by selecting any field from the main card section.  This will change the way the
cards appear in the navigation tree on the left.

To create new cards (data):
1. Select a theme or template using the Change Template button.

2. Select 'New Card' from the Edit menu or use the  New Card button.
3. If you already have a card you would like to copy, select it and choose 'Clone' from the Edit

menu.
4. Give the new card a name.
5. Fill in the data fields on the right-hand side of the screen.
6. To add comments or attachments, right-click a field and 'View Additional Information'.  If

additional information already exists, there will be a red triangle in the upper right corner of
the field.

7. You can make the card appear smaller or larger by selecting ‘Zoom’ from the Options menu

or use the  Zoom button.
8. Hide sections by deselecting them in Display Options under the Options menu or use the 

Display Options button.  You can also choose to show comments in Form View.  These will
appear at the bottom of the section they belong to.

To create new sections:
1. Sections that can have multiple records added are called repeatable sections.
2. To add new sections, use the Section View tab.

3. After choosing a repeatable section, select the  Add New button that appears above the
card.

4. Fill in the data.

5. To delete a section, select it and use the  Delete button.

To view / edit cards:
1. Select the card template you wish to use.
2. Select the specific card you want to view.
3. This will show you all the data in an editable format under the main Cards tab.

4. If you wish to rename the card, use the Edit menu and choose 'Rename' or use the 
Rename button.

5. You may see some fields with a red triangle in the upper right corner which indicates that
there is additional information (comments, voice clip, attachment, or sketch) for that field. 
You can right-click the field and select 'View Additional Information', or use the tabs along the
top of the card to view all of the additional information contained in the card.

6. Export data to Excel by using the  Excel button or File > Export menu.

7. Refresh the data by using the  Refresh button.
8. If you need to move individual repeatable sections to another parent section, select the

section to be moved using the Section View, choose the  Move To button, and select the
new section from the drop down list.
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3.2.1.4 Merging Cards

Cards can be merged together on the desktop (ie. Card 1 => Card 2).  This will take the fixed data
from the first card and update the second card, it will append any repeatable sections to second card,
the second card will keep its name, and the first card will be deleted.

To merge cards on SNAP! Client:
· click and drag the first card you want to merge onto the destination card, or
· use the  Merge Cards button and select the source and destination cards

3.2.1.5 Backup and Restore Cards

To backup and restore cards on the desktop:
Use Snap Package (.SnapPkg) exporting and importing to backup and restore data.  This method
also makes a backup of your templates and themes that you export.

3.2.1.6 Exporting Cards

To export cards, use the 'Export Cards as Snap Package' option from the 'File' > 'Export' menu. 
Select the cards to be exported and choose 'OK'.  Data can be exchanged between users with this
method.

To export to MS Excel, use the Excel options under the 'File' > 'Export' menu.

3.2.1.7 Deleting Cards

Completed cards can be deleted from SNAP! Client.  Please ensure that you no longer require this
data before deleting it as there is no way to retrieve it later.  To backup your data before deleting, 
export a Snap Package.

To delete cards (data) from the desktop:
1. To remove a single card, select it from the tree and choose 'Delete [card name]' from the Edit

menu
2. To remove multiple cards, choose 'Delete Multiple Cards' from the Edit menu, then select the

cards from the list

To delete card sections from the desktop:
1. Using the Section View tab, select the appropriate card from the tree

2. Choose the section you wish to delete, then use the  Delete button at the top of the card

3.2.1.8 Analyzing Card Data

Use the Analysis tab for compiling card data:
· Select multiple cards from the list down the left hand side
· Use  Display Options to select the sections and fields to compile, the number of columns to

freeze for scrolling, the column header height, and whether or not you wish to see statistical
calculations

· Use the  Run Report button to see a summary of the data

· Use the  Chart Data button  to see the data represented in either a bar or scatter chart

· Use the  Excel button to export the resulting data to MS Excel
· Use the Statistics tab on the bottom of the screen to show a statistics sheet (SNAP!

automatically calculates a Count, Sum, Min, Max, Mean, Confidence Interval (90), and
Standard Deviation on the data)

3.2.1.9 Printing Cards

There are several options for printing data under the File menu:
· Print – prints the currently selected card
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· Preview – shows you a sample of what the printout will look like
· Print Multiple Cards – allows you to print multiple cards at once
· Page Setup – allows you to set page size and orientation, printer, margins, etc.

3.2.2 SNAP! Mobile

This section explains how to load, share, create, edit, view, merge, download, backup and restore,
and delete cards and data on your mobile device.

3.2.2.1 Loading Cards

To send cards to the mobile device:
1. Using SNAP! Client, select the Mobile Device menu
2. In the ‘Cards’ section, select the card(s) you wish to add to the mobile device.  Cards marked

with a  status only exist on the desktop and can be selected to  upload them to
device.  If there are several that are awaiting to be uploaded, you can upload all of them at

once by selecting the  button at the bottom.
3. The selected card(s) will appear on the mobile device (after using the Reload button) where

they can be edited and sent back to the desktop

** Notes:
· Handheld data will always overwrite desktop data.  For this reason it is important to remove

completed cards from the handheld.
· If you delete any sections from a card on the handheld, they will still exist on SNAP! Client even

after syncing.  You will need to delete the sections from the card on SNAP! Client or delete the
entire card from the desktop before syncing it from the handheld.

· Any populated data fields will replace blank/empty data fields during sync.
· Desktop comments will overwrite handheld comments.
· If edits are made on the desktop that need to be reflected on the handheld, the card should be

removed from the handheld first, then synced back onto it.

3.2.2.2 Sharing Cards

You can share cards with other MS Windows Mobile device users if you have Bluetooth enabled
handhelds.  

To setup the Bluetooth connection between handhelds, go to 'Settings' > 'Connections' on the
handhelds.  On older handhelds you will select the "Beam" icon and ensure that 'Receive all incoming
beams' is checked on.  On new handhelds you will select 'Bluetooth' > 'General' or 'Bluetooth' >
'Mode' and ensure that Bluetooth in turned on.  If you have these additional options available, check
them on:

· allow other devices to connect
· other devices can discover me

To share cards with other mobile devices:
1. Ensure the receiving handheld has the same card template loaded onto it.
2. On the receiving handheld, with the card template selected, go to 'Options' > [Card Name] >

'Receive [Card Name] Cards'.
3. On the sending handheld, with the card selected, go to 'Options' > 'Card:xxx' > 'Send'

3.2.2.3 Creating, Editing and Viewing Cards

SNAP! Mobile includes several features that allow you to navigate the sections easily.  These
functions and more are also found under the Options menu in the bottom left corner.

To create, edit and view cards (data):
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1. Select the Template or Theme you wish to use from the pull down list under 'Current
Template'.

2. Select the  box beside '***CREATE NEW CARD***' to create a new card, or an existing
card name to edit.  A new card's name is defaulted to "New Card".  You can edit this to
something more recognizable to distinguish it from other cards.

3. The  Edit button allows you to enter or view data within the current section or card.
4. The  Drill button allows you to see the section(s) within the current section, going further

into the card.
5. The  Up button moves you back up to the parent section.
6. To create a new repeatable section, use the Options menu, choose the section and select

'Add New'.  Alternatively, you can click and hold the section name, then choose 'New'

7. The  Expand and  Collapse buttons allow you to show or hide repeatable sections.
8. For repeatable sections, you can enter and/or view data in a grid by using the Options menu

or click and hold the section name, then choose 'Edit in Grid'.  The columns are resizeable
and the headings have descriptions if you click on them.

9. Sections with a  Summary button beside them indicate a non-editable summary section.
These sections generally calculate values and display results from other sections.

10. Any sections that are repeatable can also be deleted using the Options menu.
11. Some fields may have minimum and/or maximum values set.  If the number you have

entered falls outside this range, you will receive a message upon pressing ‘Done’ to exit the
screen.

12. Some fields are calculated as you enter data into related fields.
13. Fields that are mandatory are in bold and highlighted in yellow.  If you have not filled them in,

you will be notified upon selecting ‘Done’.
14. For date fields, you can use the drop down calendar to select a date.  For today's date, click

and hold the date field and select 'Today...'.  To clear a date, click and hold the date field and
select 'Clear...'.

15. Every field has an  Additional Information button beside it.  Select this button to include
additional information (comment, voice clip, attachment, or sketch) for that field.  The button
turns green when it contains information.

16. Some fields have a 'Set GPS Latitude' or 'Set GPS Longitude' option under the Additional
Information.  To use this, please ensure that GPS is turned on.

17. Some fields have a  Help button beside them.  Select it to access the help text and hints
for data collection.

18. The Save option in the bottom right corner allows you to 'Save' your changes to the card or
'Save & Close' the card.

To setup default data to avoid repetitious entry:
1. On the Handheld, select a Template or Theme, then choose the Options menu from the

bottom left-hand corner of the screen, and 'Edit Defaults’.
2. Fill out the fields that you would like to be defaulted on every new card you create (note: the

defaulted data can be edited in the card).

3.2.2.4 Merging Cards

On the handheld, you can merge cards together (ie. Card 1 => Card 2).  This will take the fixed data
from the first card and update the second card, it will append any repeatable sections to second card,
the second card will keep its name, and the first card will be deleted.

To merge cards on SNAP! Mobile:
· at the Current Template screen, choose the first card you want to merge, then 'Options' >

'Card: name' > 'Merge into' > and choose the destination card.
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3.2.2.5 Downloading Cards

While a handheld is connected, you have the option to select the Mobile Device menu on the
desktop.  

Any cards that are out of sync with the desktop will be indicated with a  status.  Select the card to

sync it , or select the  Sync button at the bottom to sync all cards at once.  Any changes made
on the handheld will be reflected on the desktop, however, any changes made on the desktop will be
overwritten by the handheld.  For this reason, it is important to remove completed cards from the
handheld.

New cards created on the handheld will be indicated by a  status showing that it only exists on the

handheld.  Select the card to download  it to the desktop, or use the  button at the bottom to
download all new cards at once.

** Notes:
· Handheld data will always overwrite desktop data.  For this reason it is important to remove

completed cards from the handheld if anyone plans on making edits to the data on the desktop.
· If you delete any sections from a card on the handheld, they will still exist on SNAP! Client even

after syncing.  You will need to delete the sections from the card on SNAP! Client or delete the
entire card from the desktop before syncing it from the handheld.

· Any populated data fields will replace blank/empty data fields during sync.
· Desktop comments will overwrite handheld comments.
· If edits are made on the desktop that need to be reflected on the handheld, the card should be

removed from the handheld first, then synced back onto it.

3.2.2.6 Backup and Restore Cards

To backup cards (data) on the handheld:
From the main template list, select 'Options' > 'Backup...', then select the  template you wish to
backup from the list.  The first time you backup, you will be prompted to choose a location for a
backup folder.  If you wish to change this later, you can select 'Options' > 'Change Backup Folder'
and select a new location.

To restore a backup on the handheld:
From the main template list, select 'Options' > 'Restore', then select the backup folder.  You will be
prompted for which cards to restore.

3.2.2.7 Deleting Cards

Completed cards can be deleted from SNAP! Mobile.  Please ensure that you no longer require this
data before deleting it as there is no way to retrieve it later. 

To delete cards (data) from the handheld:
OPTION 1 - If your handheld is connected to your PC, you can use SNAP! Client to delete cards
from the handheld:
1. Select the Mobile Device menu
2. In the Cards section, select the cards that are synced  and can be removed  that you

wish to delete, or select the  button at the bottom of the screen.
3. You can also remove the Template and/or Theme associated with the cards by choosing

them under the Templates section

OPTION 2:
1. On the handheld, select the card from the main SNAP! window
2. Choose ‘Options…Card:xxx...Delete’ from the bottom left-hand corner of the screen
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3. Follow the onscreen instructions

3.2.2.8 Exiting

To properly close SNAP! on the handheld, choose 'Options... Close SNAP' from the main screen.  If
you use the 'X' in the upper right-hand corner, SNAP! will still be running in the background.

3.2.3 iSNAP!

This section explains how to load, create, edit, view, download, and delete cards and data on your
iPhone or iPod Touch.

3.2.3.1 Loading Cards

The process for loading cards onto iSNAP! is the same for loading templates and themes.  Please
refer to the iSNAP! > Loading Templates / Themes section for more information.

** Notes:
· Handheld data will always overwrite desktop data.  For this reason it is important to remove

completed cards from iSNAP.
· If you delete any sections from a card on iSNAP, they will still exist on SNAP! Client even after

syncing.  You will need to delete the sections from the card on SNAP! Client or delete the entire
card from the desktop before syncing it from iSNAP.

· Any populated data fields will replace blank/empty data fields during sync.
· Desktop comments will overwrite handheld comments.

3.2.3.2 Creating, Editing and Viewing Cards

To create, edit and view cards (data):
1. Select the Project you wish to use from the list under 'Please Select a Project'.

2. Select the  New Card button in the top right to create a new card, or an existing card
name to edit.

3. The  Drill button allows you to enter or view data within the section and see other

section(s) within it.  The  Drill button with two arrows indicates a repeatable section.
4. The Back button moves you back up to the previous section.
5. To create or delete a repeatable section, use the '+' and '-' buttons in the bottom left of the

repeatable section window.
6. For repeatable sections, you can enter and/or view data in a grid by using the Grid button in

the bottom right of the repeatable section window.
7. Some fields may have minimum and/or maximum values set.  If the number you have

entered falls outside this range, it will appear in red.
8. Some fields are calculated as you enter data into related fields.
9. Fields that are mandatory are highlighted in yellow.  If you have not filled them in, you will be

notified upon selecting ‘Done’.
10. Every field has an option for Attachments below it or by using the the paper clip icon in the

top right.  This feature allows you to include additional information (pictures, voice
recordings, sketches, or comments) for any field.

11. Some fields have a 'Set GPS Latitude' or 'Set GPS Longitude' option.  To use this, please
ensure that Location Services are turned on for iSNAP in your iPhone or iPod settings.

12. Some fields have helpful hints below them.  This information can be setup in Theme.
13. The Save option in the top right corner allows you to save changes to the card and close it.

To setup default data to avoid repetitious entry:
1. Certain fields have a 'Default Value' option.  When you select the field to fill it in, there will be

an option at the bottom to 'Set Default Value'.  Whatever you have entered into the field now
becomes the default value for every new card.

2. You can overwrite the value and set a new default value at any time.
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3.2.3.3 Downloading Cards

To import cards from iSNAP to SNAP! Client, use the  Dropbox button on the iPhone or iPod
Touch.  Choose the project you wish to upload to Dropbox.  You will have the option to send just your
changed cards, or sync everything.

Both options will automatically import any new cards created on iSNAP for the project specified.  The
data from iSNAP will be merged into any matching cards on Dropbox.  

** Notes:
· Handheld data will always overwrite desktop data.  For this reason it is important to sync only 'My

changed cards' from iSNAP.
· If you delete any sections from a card on iSNAP, they will still exist on SNAP! Client even after

syncing.  You will need to delete the sections from the card on SNAP! Client or delete the entire
card from the desktop before syncing it from iSNAP.

· Any populated data fields will replace blank/empty data fields during sync.
· Desktop comments will overwrite handheld comments.

3.2.3.4 Deleting Cards

To delete templates / themes / cards from the iPhone or iPod Touch, you first need to sync with
Dropbox.  Once synced, the project will get a green check mark beside it.  Swipe your finger to the
left or right on the project and the check mark will become a Delete button.  Use this to delete the
project (which will delete all related cards).
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4 Using SNAP! Survey Wizard

There are currently two templates for SNAP! Survey Wizard: 
· BC SURVEY - Single Story
· BC SURVEY - Multi Story

These two templates are based on the BC Silviculture Survey Procedures from April 1, 2011.

When using the Survey Wizard templates, three new tabs appear: Reports, Imports, and Exports.

4.1 Single Story Surveys

The BC SURVEY - Single Story template allows you to create and record survey card data in the
field, download it to the desktop, report it, share it, then export it to Excel, Cengea (Genus), TFM, and
Phoenix.

The template was designed based on the BC Silviculture Survey Procedures and contains the
following sections:
· Block
· External Block Data
· Strata

· Site Description
· Silviculture Standards
· Species Standards
· General Site Information
· External Stratum Data
· Plots

· Species Tallies
· Pest Data
· Brush Data

· Stocking Summary (breakdown of WS, FG, TS, Ages, and Heights by species)
· Pest Summary (breakdown of pest incidence by species)
· Brush Summary (breakdown of brush heights by species)
· WS Statistical Calculations
· FG Statistical Calculations

Any of these sections can be hidden on the desktop if you do not wish to use them.

These important fields should be reviewed and the data collected (depending on the end purpose):

Section Field Required for:
Block Licence Export to Cengea (Genus)

*must match Activity Name in Genus
**used to produce the Inventory
Label

CP Number
Block
Field Finish Date
Survey Objectives*
Inventory Label Source**

External Block Data Division ID
External Unique Activity ID Export to TFM

Strata Stratum Name Exports and reports
Survey Status Exports
Stocking Status Silviculture label, export to TFM,

reports
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Site Description Silv Site Index Silviculture label, exports
Inv Site Index Inventory label, exports
SI Source Silviculture and inventory labels,

exports
Silviculture Standards Target SPH Calculating M Values for reports and

exports
Plot Multiplier Calculating stems per hectare for

reports and exports
Species Standards Tree Species Determining WS & FG SPH versus

WS & FG preferred SPH for reports
and exports

Preferred
Acceptable
Coniferous Calculating total conifers/ha for

reports and exports
External Stratum Data Inv Status Exports

Inv Type
Silv Status
Silv Type
Export FG #s? Exporting FG versus WS numbers

for reports and exports
Plot Plot Name Calculating # of plots for reports and

exports
Total Trees by Layer (only if
recording Inv Label % by species)

Calculating TS SPH, TS%, inventory
label for reports and exports

Species Tallies Tree Species Determining WS, FG, and TS SPH,
species % breakdowns, silviculture
and inventory labels for reports and
exports

Well Spaced
Free Growing (if FG Survey)
Total Trees (if not recording Inv
Label %)
Inv Label % (if not tallying total
trees by species)

Determining TS SPH, TS%,
inventory label for reports and
exports

Sample Ages and Heights in
sample plots

Creating silviculture and inventory
labels for reports and exports

Pest Data all fields if pest is recorded Calculating % host trees affected for
reports and exports

Brush Data all fields if brush is recorded Calculating average % cover and
heights for reports and exports

4.2 Multi Story Surveys

The BC SURVEY - Multi Story template allows you to create and record survey card data in the field,
download it to the desktop, report it, share it, then export it to Excel, TFM, and Phoenix.

The template was designed based on the BC Silviculture Survey Procedures and contains the
following sections:
· Block
· External Block Data
· Strata

· Site Description
· Silviculture Standards (Layers 1,-4)
· Species Standards
· General Site Information
· External System Data
· Plots
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· Layer 1-4 Species Tallies
· Layer 1-4 Pest Data
· Brush Data

· WS Summary (summary of WS sph by layer)
· FG Summary (summary of FG sph by layer)
· Inv Summary (summary of Total Trees sph and Total Conifers sph by layer)
· Stocking Layer 1-4 (breakdown of WS, FG, TS, Ages, Heights by species by layer)
· Pest Layer 1-4 (breakdown of pest incidence by species by layer)
· Brush Summary (summary of brush heights by species)

Any of these sections can be hidden on the desktop if you do not wish to use them.

These important fields should be reviewed and the data collected (depending on the end purpose):

Section Field Required for:
Block Licence Export to Cengea (Genus)

*must match Activity Name in Genus
**used to produce the Inventory
Label

CP Number
Block
Field Finish Date
Survey Objectives*
Inventory Label Source**

External Block Data Division ID
External Unique Activity ID Export to TFM

Strata Stratum Name Exports and reports
Survey Status Exports
Stocking Status Silviculture label, export to TFM,

reports
Site Description Silv Site Index Silviculture label, exports

Inv Site Index Inventory label, exports
SI Source Silviculture and inventory labels,

exports
Silviculture Standards Target SPH Calculating M Values for reports and

exports
Plot Multiplier Calculating stems per hectare for

reports and exports
Species Standards Tree Species Determining WS & FG SPH versus

WS & FG preferred SPH for reports
and exports

Preferred
Acceptable
Coniferous Calculating total conifers/ha for

reports and exports
External Stratum Data Inv Status Exports

Inv Type
Silv Status
Silv Type
Export FG #s? Exporting FG versus WS numbers

for reports and exports
Plot Plot Name Calculating # of plots for reports and

exports
Total Trees by Layer (only if
recording Inv Label % by species)

Calculating TS SPH, TS%, inventory
label for reports and exports

Species Tallies Tree Species Determining WS, FG, and TS SPH,
species % breakdowns, silviculture
and inventory labels for reports and
exports

Well Spaced
Free Growing (if FG Survey)
Total Trees (if not recording Inv
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Label %)
Inv Label % (if not tallying total
trees by species)

Determining TS SPH, TS%,
inventory label for reports and
exports

Sample Ages and Heights in
sample plots

Creating silviculture and inventory
labels for reports and exports

Pest Data all fields if pest is recorded Calculating % host trees affected for
reports and exports

Brush Data all fields if brush is recorded Calculating average % cover and
heights for reports and exports

4.3 Reports

There are several reports available for Survey Wizard:
· Phoenix Export
· Pest Info
· Map Legend
· Plot Card
· Single Story Report
· Multi Story Report

To print any of the reports, run them, then use the Export to Excel button in the top left corner and
print from Excel.

4.4 Import from .SW3 File

In addition to the regular method of loading card data, Survey Wizard can also import from an .sw3
file (legacy Survey Wizard export format).

To import from an .SW3 file:
1. Select either the BC SURVEY - Single Story or the BC SURVEY - Multi Story template

depending on the data you will be importing.
2. Select the Imports tab, then the Import button next to 'Import From an SW3 file'.  
3. Locate the .sw3 file you wish  to import.  
4. The importer will state how many cards were imported.  Each imported card will be named

with the prefix 'Imported', followed by the Block, CP Number, and Timbermark of the card.  

** Note:  Only fields that existed in the legacy Survey Wizard program will be imported into SNAP!
Survey Wizard.

4.5 Exports

There are several exports available for Survey Wizard:
· Export to TFM
· Phoenix Export
· Export to Files for Genus Import

4.5.1 Export to TFM

Using the Exports tab, choose the Export button beside 'Export to TFM'.  Select the card(s) you wish
to export.
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The export to TFM (TheForestManager) requires a schema file (.xsd) to validate against.  You will
need to obtain one and place it in a location where it can be readily accessed.  This file validates the
data as it is being exported to ensure that the format and data are correct.  This should be the same
as the validation performed upon subsequent import to TFM.

You can specify a date format if the one TFM uses is different than the one displayed.

Specify an export location.  This is where the resulting .xml file will be saved.

If there are any problems with the format of the file or the data itself, you will be presented with a
Validation Errors screen that will describe the issues found.  Typical errors would include using the
wrong species codes, pest codes, brush codes, etc.

The export produces an .xml file that can then be used for import into TFM.

4.5.2 Export to Phoenix Pro

The Phoenix Export can be accessed through the Exports tab or the Report tab.  It is produced as a
report that can be exported to Excel and saved.  The resulting Excel file can be imported into
Phoenix Pro.

4.5.3 Export to Cengea Forest

The export to Cengea Forest (Genus) function is found under the Exports tab.  Select the card(s) you
wish to export, then select a location to save the exported files.  The files will be placed in a folder
prefixed 'Exported' followed by a date and time stamp.  There will be six files exported for import into
Cengea via the Import Tool.
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5 Appendix A: Troubleshooting

Handheld:

Problem:  "Error - This application (SnapMobile) requires a newer version of the Microsoft .NET
Compact Framework than the version installed on this device."

Solution:  Download and install Microsoft .NET Compact Framework 3.5 from
http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3
385&displaylang=en

Problem:  "Error - SnapMobile.exe:  InvalidProgramException"

Solution:  Download and install Microsoft .NET Compact Framework 3.5 from
http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3
385&displaylang=en

Problem:  ".NET CF Initialization Error - The application failed to load required components.  If the .
NET Compact Framework is installed on a storage card, please ensure that this card is in place and
launch the application again.  If this fails, a re-installation of the .NET Compact Framework is
recommended."

Solution:  Follow the instructions within the error message, ensuring that you have downloaded
and installed Microsoft .NET Compact Framework 3.5 from www.microsoft.com/downloads.

** Please Note:  All other versions of .NET Compact Framework 3.5 must be removed from your
handheld.  To do so, go to Settings... System... Remove Programs and browse for previous versions
of .NET CF.  If there are any previous versions and you are having trouble running SNAP!, please
select the older version and choose 'Remove'.

Problem:  "Could not create directory" error when trying to install SNAP! on the Windows handheld.

Solution:  Download the version for mobile device from the website at http://www.jrpltd.com/
Support/Updates.aspx?Product=SNAP and put the file onto the handheld.  Run the .CAB file on
the handheld to install SNAP! Mobile.

http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3385&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3385&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3385&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=e3821449-3c6b-42f1-9fd9-0041345b3385&displaylang=en
http://www.microsoft.com/downloads
http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP
http://www.jrpltd.com/Support/Updates.aspx?Product=SNAP
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6 Appendix B: Technical Support

Help Desk:
Technical support is available for licensed SNAP! dcs users.  The Help Desk is open Monday to
Friday, 8:00 a.m. to 5:00 p.m. PST.  We are closed for Canadian statutory holidays.

Phone:  1-800-535-2093 ext. 300 or (250) 703-0451 ext. 300
E-mail:  support@jrpltd.com

Please have the following information available when contacting us:
· PC Operating system (i.e. Windows version)
· Windows CE/Mobile version
· SNAP! version
· Any error messages that may have occurred

mailto:support@jrpltd.com
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